.NET 3.5 Installation

Topics: bug
Apr 30, 2013 at 9:57 PM
Hi,

When I use Package Manager Console then I get the following error:
PM> Install-Package QuickGraph
Installing 'QuickGraph 3.6.61119.7'.
Successfully installed 'QuickGraph 3.6.61119.7'.
Adding 'QuickGraph 3.6.61119.7' to AuthorPlugIns.
Uninstalling 'QuickGraph 3.6.61119.7'.
Successfully uninstalled 'QuickGraph 3.6.61119.7'.
Install failed. Rolling back...
Install-Package : Could not install package 'QuickGraph 3.6.61119.7'. You are trying to install this pac
kage into a project that targets '.NETFramework,Version=v3.5', but the package does not contain any asse
mbly references or content files that are compatible with that framework. For more information, contact 
the package author.
At line:1 char:16
+ Install-Package <<<<  QuickGraph
    + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCom 
   mand
 
I also tried adding it to .NET 2.0 using GUI and it didn't show the project as one I could add it to. I cannot upgrade to .NET 4 because I'm developing a plug-in for something that is built on .NET 3.5.

How can I install QuickGraph for .NET 3.5 project?

Thanks
Oct 31, 2013 at 7:09 PM
I would like to be able to use a NuGet 3.5 compatible package also, can one be added?